Compter le nombre d'occurrences Excel

Comment compter le nombre d’occurrences d’une valeur Excel !

Apprenez à compter rapidement les occurrences d'une ou plusieurs valeurs dans Excel avec notre guide simple. Idéal pour débutants et pros !
Partagez facilement cette ressource avec vos collègues 📲
4.9
(7)

Compter le nombre d'occurrences sur Excel simplement ? Le comptage fait partie de l’analyse des données et avec les bons outils et les bonnes méthodes, c'est simple ! Avec Excel, différentes fonctions vont te permettre de compter des cellules, des lignes ou encore des colonnes de données.

Ce tuto va te donner plusieurs méthodes pour te permettre de compter le nombre total d’occurrences. L'idée de cet article est de te donner les meilleures méthodes pour compter le nombre de fois qu'un mot apparait dans ton fichier Excel.

MéthodeDescriptionFormule Exemple
Fonction NB.SICompte le nombre de cellules qui répondent à un critère unique.=NB.SI(plage; critère)
Fonction NB.SI.ENSCompte le nombre de cellules qui répondent à plusieurs critères.=NB.SI.ENS(plage_critères1; critère1; [plage_critères2]; [critère2]; ...)
Fonction FRÉQUENCEPermet de calculer la fréquence des valeurs dans une plage de données. Utile pour les données numériques.=FREQUENCE(données; classes)
Tableau croisé dynamiquePermet d'analyser, de résumer et de présenter des données. Idéal pour compter les occurrences dans des ensembles de données complexes.Pas de formule, utilisation via l'interface Excel.
Formules matriciellesUtilise des formules complexes pour calculer des occurrences, souvent en combinaison avec les fonctions SOMME, SI et d'autres.={SOMME(SI(plage=critère; 1; 0))} (Entrée avec Ctrl+Maj+Entrée)
Compléments (Add-ins) ExcelDes outils tiers peuvent être installés pour étendre les fonctionnalités d'Excel, y compris pour compter les occurrences de manière plus avancée.Dépend du complément installé.
Tableau Récapitulatif : compter le nombre d'occurrences Excel

Chaque méthode a ses avantages en fonction de la nature des données et des besoins spécifiques de l'utilisateur.

  • Pour des besoins simples : NB.SI ou NB.SI.ENS suffisent généralement.
  • Pour mieux gérer des données complexes ou des multiples critères : je te conseille les tableaux croisés dynamiques ou les formules matricielles.

Besoin simple : la fonction NB.SI

Avec cette fonction, tu souhaites afficher le nombre de fois qu’un élément apparait. Dans la cellule où tu veux afficher le résultat du comptage, tu saisis la fonction =NB.SI()

Exemple : déterminer le nombre de fois où un nom apparait avec la fonction NB.SI

1 - Comme dans l’exemple suivant, tu souhaites déterminer le nombre de fois où le nom Cécile apparait

exemple compter occurrences Excel
Étape 2 :

Tu saisis la plage de cellules à prendre en compte et le critère. Dans l’exemple, cela donne   =NB.SI(A1:A13;"Cécile") et fait ENTREE

Saisie formule dans cellules
Étape 3 :

Le résultat va s’afficher LE NOMBRE D’OCCURENCE où apparait « Cécile », dans l’exemple : 2

Cela fonctionne aussi bien avec le critère de mot et de nombres

r‚sultat nb si

Et voilà, tu sais maintenant compter le nombre d'occurrence dans une colonne sur Excel avec la fonction NB.SI.

D'ailleurs, nous t'avons réalisé une fiche de révision complète sur la fonction NB.SI. Cliquez ici pour la récupérer.

Excel : l'outil que tout le monde connait… mais que personne n'exploite à plein potentiel !

Morpheus Formation est un organisme certifié spécialisé sur Excel avec formations finançables par niveau, métier ou compétences recherchées.

Notre méthode d'apprentissage est déjà testée et approuvée par plusieurs grandes entreprises (CAC 40) et plus de 200 apprenants avec un taux de satisfaction de 9,8 sur 10 en 2024 !

Critères multiples : NB.SI.ENS

Tu peux aussi compter le nombre d’occurrences en fonction de plusieurs critères.

Avec cette fonction, tu peux compter le nombre d'occurrences de plusieurs valeurs.

Exemple : compter le nombreux d’occurrences avec NB.SI.ENS

Dans l’exemple suivant, tu veux compter le nombre d’employés qui sont à l’étage « 4 » au service « Ventes ».

La formule devient =NB.SI.ENS(C2:C13;"4";B2:B13;"Ventes")

NB.SI.ENS


Pour les utilisateurs avancés : formules Matricielles

Formule matricielle 1 : fonction NB et SI

Tu peux aussi associer les fonctions NB et SI lorsque tu veux par exemple déterminer combien de vendeurs ont vendu un type d’article.

Tu devras d’abord utiliser la fonction SI pour tester la condition, puis uniquement si le résultat de la condition SI est vrai, tu utilises la fonction NB pour compter les occurrences.

Exemple : Fonction NB et SI

Dans l’exemple suivant, tu veux connaitre le nombre de ventes de « Livres » dans la région « Sud »

Dans cet exemple, la formule est entrée sous forme de formule matricielle. Il te faudra valider par Ctrl+Maj+Entrée pour obtenir le résultat

La formule matricielle sera =NB(SI((A2:A9="Sud")*(C2:C9="Livres");D2:D9)

NB+SI

Formule matricielle 2 : la fonction SOMME et SI.

Tu peux aussi utiliser les fonctions SOMME et SI conjointement.

Exemple SOMME et SI

Dans cet exemple, tu souhaites connaitre le nombre de factures pour les vendeurs Frédéric et Alain 

La formule matricielle sera =SOMME(SI((A2:A9="Fréderic")+(A2:A9="Alain");1;0))

Il te faut aussi valider cette formule avec Ctrl+Maj+Entrée pour obtenir le résultat

SOMME+SI

L’outil idéal : Tableau croisé dynamique

Tu peux aussi connaitre le nombre d’occurrences lorsque tu crées un Tableau croisé dynamique.

Exemple : tableau croisé dynamique pour compter les occurences

Dans l’exemple suivant, tu crées un TCD en sélectionnant la plage de cellules A2:C8

TCD Exemple

Crée ton TCD dans une nouvelle feuille de calcul et dans le volet de tableau croisé dynamique, fais glisser Article vers la zone Ligne, Trimestre vers la zone colonne, ventes vers la zone Valeurs, et répètes de nouveau Ventes vers la zone Valeurs.

Tu trouveras le nom du champ qui s’affiche « Somme de Ventes2 » comme dans cet exemple

champ TCD

Dans la zone Valeurs, clique sur la flèche de Somme de ventes2 et sélectionne Paramètres des champs de valeurs.

Sélectionne « Nombre » dans « le champ de valeur par » et remplace le nom par « Nombre » dans le « Nom personnalisé » comme dans l’exemple

Parametres champs de valeurs

Il te reste à faire OK pour trouver le résultat de ton tableau avec les colonnes « Nombres » et « Total Nombre »

Parametres champs de valeurs

Formation Tableau Croisé Dynamique

Pour progresser rapidement sur les TCD, on te propose une formation spécifique :

Formation Spécifique sur Excel

Compter le nombre d’occurrences de plusieurs valeurs

Pour compter le nombre d'occurrences de plusieurs valeurs dans Excel, tu peux utiliser différentes méthodes.

Voici un résumé des méthodes applicables :

MéthodeDescriptionFormule Exemple
Fonction NB.SIUtilisez NB.SI dans une formule matricielle pour compter les occurrences de valeurs spécifiques dans une plage.=SOMME(NB.SI(plage; {"valeur1";"valeur2";"valeur3"}))
Fonction NB.SI.ENSUtilisez NB.SI.ENS pour compter les occurrences en fonction de plusieurs critères sur des plages différentes.=NB.SI.ENS(plage_critères; "valeur1")+NB.SI.ENS(plage_critères; "valeur2")
Fonction SOMMEPRODCompte les occurrences de plusieurs valeurs en utilisant une approche conditionnelle.=SOMMEPROD((plage="valeur1")+(plage="valeur2"))
Fonctions CHAINEPour les données textuelles, combiner des fonctions pour compter les occurrences de sous-chaînes.=NB.SI(plage; "*valeur1*")+NB.SI(plage; "*valeur2*")
Tableau Croisé DynamiqueCréez un tableau croisé dynamique pour résumer les occurrences de chaque valeur unique.Pas de formule, utilisez l'interface Excel.
compter le nombre d'occurrences de plusieurs valeurs dans Excel

Notre avis :

  • La fonction NB.SI dans une formule matricielle et SOMMEPROD sont particulièrement utiles pour compter directement plusieurs valeurs.
  • Les fonctions NB.SI.ENS et les chaînes de texte avec NB.SI sont plus adaptées pour des critères spécifiques ou pour compter des occurrences de sous-chaînes dans des textes.
  • Les tableaux croisés dynamiques offrent une approche visuelle et interactive pour analyser et compter les occurrences sans nécessiter de formule. On adore !

Cas Pratique à télécharger : Compter le nombre d’occurrences Excel

Si tu souhaites t'améliorer sur ce sujet, je te conseille notre fichier d'exercice gratuit :

FAQ : Compter le nombre d’occurrences Excel

Quelle est la formule pour compter le nombre d’occurrences dans une colonne Excel ?

Utilisez la formule =NB.SI(plage; critère) pour compter le nombre d'occurrences d'une valeur spécifique dans une colonne. Remplacez plage par la plage de cellules à vérifier et critère par la valeur spécifique à compter.

Comment utiliser un tableau croisé dynamique pour compter le nombre d’occurrences ?

  1. Sélectionnez votre plage de données.
  2. Allez dans Insertion > Tableau croisé dynamique.
  3. Choisissez votre plage de données et l'emplacement du TCD.
  4. Dans le TCD, glissez la colonne pour laquelle vous souhaitez compter les occurrences dans la zone Lignes et la même colonne (ou une autre) dans la zone Valeurs. Choisissez l'option "Nombre" pour l'agrégation.

Comment compter le nombre d’occurrences d’une valeur avec plusieurs conditions ?

Utilisez la fonction NB.SI.ENS(plage_critères1; critère1; [plage_critères2; critère2]; ...). Cette fonction permet de compter les cellules qui répondent à plusieurs critères.

Existe-t-il une fonction pour compter les occurrences uniques dans une colonne ?

Pour compter les occurrences uniques, utilisez la combinaison de fonctions =SOMMEPROD((plage<>"")/NB.SI(plage; plage)) sur Excel versions antérieures ou =NBVAL.UNIQUE(plage) dans Excel pour Microsoft 365.

Comment compter le nombre de fois qu’une valeur apparaît dans plusieurs colonnes ?

Vous pouvez utiliser une formule matricielle avec NB.SI pour chaque colonne et les additionner ou créer une formule unique avec SOMME(NB.SI(plages; critère)), en remplaçant plages par une combinaison de plages séparées par des virgules et critère par la valeur à compter.

Comment calculer la médiane dans Excel ?

Utilisez la fonction =MEDIANE(plage) pour calculer la médiane d'une série de valeurs. Remplacez plage par la plage de cellules contenant les valeurs.

Peut-on compter le nombre d’occurrences dans Excel à l’aide de Power BI ou de LibreOffice Calc ?

Oui, dans Power BI, vous pouvez utiliser des fonctions DAX comme COUNTROWS() avec des filtres appropriés. Dans LibreOffice Calc, les fonctions sont similaires à Excel, telles que NB.SI() pour compter les occurrences.

Comment bloquer une valeur dans une formule Excel ?

Pour bloquer une valeur ou une référence de cellule dans une formule, utilisez le symbole $ avant la colonne et/ou le numéro de ligne (par exemple, $A$1). Cela crée une référence absolue, qui ne change pas lorsque la formule est copiée ailleurs.

Comment utiliser la fonction NB.SI.ENS pour compter les occurrences selon plusieurs critères ?

La fonction NB.SI.ENS permet de compter les cellules qui répondent à plusieurs critères. La syntaxe est =NB.SI.ENS(plage_critères1; critère1; [plage_critères2; critère2]; ...). Remplacez chaque plage_critères par la plage de cellules à évaluer et chaque critère par la condition spécifique à vérifier.

As-tu aimé cet article ?

Clique sur l'étoile pour l'évaluer !

Note moyenne 4.9 / 5. Nombre de votes : 7

Aucun vote jusqu'à présent ! Tu peux être le premier à évaluer cet article.

Nicolas Parent

Nicolas Parent

Avez-vous déjà remarqué combien il peut être long de simplifier les choses complexes ? En tant que formateur Excel diplômé de Comptabilité et de Gestion (DCG) chez Morpheus Formation, je m'efforce de vulgariser Excel pour en faciliter l'apprentissage auprès de nos fidèles lecteurs. Mon objectif est de vous aider à maîtriser les outils modernes du logiciel (Power Query, tableaux croisés dynamiques...) afin que vous puissiez travailler de manière plus confiante et efficace.

Articles: 122

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

LES 25 FONCTIONS EXCEL les plus utilisées !
Félicitations ! Ton ebook Excel offert !
EXERCICES | FICHES | EXEMPLES
LES 25 FONCTIONS EXCEL LES PLUS UTILISÉES !
E-book Excel offert
Vous souhaitez progresser rapidement et exploiter le plein potentiel d'Excel ? Découvrez dès maintenant notre formation adaptée à votre niveau !
Choisissez votre formation Excel !