si contient excel

Fonction SI avec "Contient" dans Excel

La fonction SI à elle seule ne permet pas de tester des conditions de type "contient". Découvrons comment le faire avec NB.SI.ENS.
Partagez facilement cette ressource avec vos collègues 📲
5
(15)

L'utilisation d'Excel ne se limite pas à de simples opérations arithmétiques. Pour les professionnels cherchant à optimiser leurs tableaux de bord, la maîtrise des fonctions avancées est cruciale. La fonction SI avec la condition "contient" sur Excel est particulièrement puissante pour gérer des données textuelles.

Dans cet article, nous vous montrerons comment utiliser cette fonction pour afficher des résultats conditionnels basés sur la présence d'une chaîne de caractères spécifique. Vous apprendrez à intégrer cette technique dans vos analyses pour gagner en efficacité.

La fonction SI à elle seule ne permet pas de tester des conditions de type "contient", "commence par" ou "se termine par".

On va donc utiliser NB.SI.ENS (ou NB.SI) dans le test logique de la fonction SI et le symbole * dans le critère de la fonction NB.SI.ENS pour compter les cellules qui "commencent par", "contiennent" ou "se terminent par".

Comment utiliser la fonction SI avec la condition "Contient" dans Excel ?

Le symbole * signifie "peu importe ce qu'il y a". Voici le récapitulatif de la définition des trois critères avec le symbole * :

  • "Critère*" signifie "commence par" (peu importe ce qu'il y a avant)
  • "*Critère*" signifie "contient" (peu importe ce qu'il y a avant et après)
  • "*Critère" signifie "se termine par" (peu importe ce qu'il y a après)

Comprendre la Fonction SI et la Condition “Contient” dans Excel

La fonction SI dans Excel permet de tester une condition et de renvoyer une valeur si la condition est vraie et une autre valeur si elle est fausse.

Pour vérifier si une cellule contient une certaine chaîne de caractères, nous utiliserons la fonction NB.SI.

Comment utiliser la Fonction SI avec “Contient”

Préparer les données :

Imaginez que vous avez une colonne de codes de production, et vous souhaitez afficher "Fabrication" si le code contient la lettre "F", et "Assemblage" sinon.Voici un exemple de votre colonne de codes :

Utiliser la fonction NB.SI :

  • La fonction NB.SI (ou COUNTIF en anglais) compte le nombre de cellules qui respectent un critère donné. Nous l'utiliserons pour vérifier si une cellule contient la lettre "F".
  • Exemple de formule : =NB.SI(A2; "*F*")
  • Cette formule renvoie 1 si la cellule A2 contient "F" et 0 sinon.
Utiliser la fonction NB.SI

Intégrer la Fonction NB.SI dans la Fonction SI :

  • Nous imbriquerons la fonction NB.SI dans la fonction SI pour afficher "Fabrication" ou "Assemblage".
  • Exemple de formule : =SI(NB.SI(A2; "*F*")>0; "Fabrication"; "Assemblage")
  • Cette formule teste si NB.SI renvoie un nombre supérieur à 0 (ce qui signifie que la lettre "F" est présente). Si c'est le cas, elle affiche "Fabrication", sinon "Assemblage".
Fonction NB.SI dans la Fonction SI
Fonction NB.SI dans la Fonction SI

Appliquer la formule à toutes les lignes :

Après avoir entré la formule dans la première cellule, double-cliquez sur le petit carré en bas à droite de la cellule pour étendre la formule à toute la colonne.

Exemple Pratique

Voici un tableau illustrant l'utilisation de la formule :

CodeRésultat
F123Fabrication
A456Assemblage
B789Assemblage
F101Fabrication
Exemple pour la fonction SI et CONTIENT

Astuces et Conseils

  • Assurez-vous que vos critères de texte dans NB.SI sont entre guillemets et utilisent des jokers (* pour tout caractère).
  • Pour des critères plus complexes, combinez plusieurs fonctions dans la formule SI.
  • Utilisez cette technique pour filtrer ou catégoriser des données textuelles de manière dynamique.

FAQ : si contient excel

Q : La fonction NB.SI ne fonctionne pas avec certains caractères spéciaux. Que faire ? R : Utilisez des caractères d'échappement ou des fonctions de texte avancées pour gérer les caractères spéciaux.

Q : Puis-je utiliser cette méthode avec des chiffres ? R : Oui, vous pouvez adapter cette méthode pour vérifier la présence de chiffres spécifiques en ajustant le critère de la fonction NB.SI.

Q : Comment puis-je gérer des critères multiples ? R : Vous pouvez imbriquer plusieurs fonctions NB.SI ou utiliser des fonctions logiques comme ET et OU pour gérer des critères multiples.


Maîtriser la fonction SI avec la condition "contient" dans Excel vous permet de manipuler vos données textuelles de manière efficace et précise.

En suivant les étapes décrites, vous pouvez rapidement automatiser l'affichage de résultats conditionnels dans vos tableaux

. N'hésitez pas à appliquer cette méthode dans vos analyses quotidiennes pour gagner du temps et améliorer la lisibilité de vos données.

Pour plus de formations avancées sur Excel, rejoignez nos sessions chez Morpheus Formation.

As-tu aimé cet article ?

Clique sur l'étoile pour l'évaluer !

Note moyenne 5 / 5. Nombre de votes : 15

Aucun vote jusqu'à présent ! Tu peux être le premier à évaluer cet article.

Nicolas Parent

Nicolas Parent

Avez-vous déjà remarqué combien il peut être long de simplifier les choses complexes ? En tant que formateur Excel diplômé de Comptabilité et de Gestion (DCG) chez Morpheus Formation, je m'efforce de vulgariser Excel pour en faciliter l'apprentissage auprès de nos fidèles lecteurs. Mon objectif est de vous aider à maîtriser les outils modernes du logiciel (Power Query, tableaux croisés dynamiques...) afin que vous puissiez travailler de manière plus confiante et efficace.

Articles: 147

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

LES 25 FONCTIONS EXCEL les plus utilisées !
Félicitations ! Ton ebook Excel offert !
EXERCICES | FICHES | EXEMPLES
LES 25 FONCTIONS EXCEL LES PLUS UTILISÉES !
E-book Excel offert
Vous souhaitez progresser rapidement et exploiter le plein potentiel d'Excel ? Découvrez dès maintenant notre formation adaptée à votre niveau !
Choisissez votre formation Excel !
Créateur de Contenus sur EXCEL
Rejoignez notre équipe dès maintenant
Nous recherchons une personne (basée à Metz est un +) avec un niveau avancé sur Excel pour nous soutenir dans la création de contenus.
  • Maîtrise avancée d'Excel, y compris Power Query.
  • Passion pour l'enseignement et la création de contenus pédagogiques.
  • Poste flexible adapté aux formateurs, indépendants, étudiants ou ceux cherchant un emploi complémentaire.